Compile Error On Magento 2.2.9 CE

Created by Rosa Truong, Modified on Wed, 31 Jul 2019 at 02:11 PM by Rosa Truong

Issue:

I have installed version 2.2.0 on Magento 2.2.9 CE and I am getting the following error in the terminal when running setup:di:compile:

Fatal error: Access level to Bss\MultiStoreViewPricingTierPrice\Model\Product\Attribute\Backend\Tierprice\UpdateHandler::$groupManagement must be protected (as in class Magento\Catalog\Model\Product\Attribute\Backend\TierPrice\UpdateHandler) or weaker in /app/code/Bss/MultiStoreViewPricingTierPrice/Model/Product/Attribute/Backend/Tierprice/UpdateHandler.php on line 298



Solution:

Could you please edit and upload the attachment file to override to the file path app/code/Bss/MultiStoreViewPricingTierPrice/Model/Product/Attribute/Backend/Tierprice/UpdateHandler.php?


If you need further assistance, please don't hesitate to contact us.


Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry! We couldn't be helpful

Thank you for your feedback

Let us how can we improve this article!

Select atleast one of the reasons

Feedback sent

We apprciate your effort and will try to fix the article