[v1.0.8] How to fix the incompatibility with M2.2.9?

Created by Rosa Truong, Modified on Wed, 13 Oct 2021 at 05:08 PM by Rosa Truong

Issue: 


I try to install your module Category Import/Export. When I try to compile I got the following error: 

Fatal error: Interface 'Magento\Framework\App\Action\HttpGetActionInterface' not found in /app/code/Bss/ImportExportCore/Controller/Adminhtml/History/Download.php on line 27

 I'm using Magento 2.2.9 CE. Can you please help me?


Solution: 


The issue happens because the current version 1.0.8 is not compatible with M2.2.x at this time.

We have modified two files to resolve the issue.

app/code/Bss/ImportExportCore/Controller/Adminhtml/History/Download.php

app/code/Bss/ImportExportCore/Controller/Adminhtml/Import/Validate.php


Please check and apply the attachment files on your site.


If you need any further assistance, please feel free to contact us.

We're more than happy to support you.

Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry! We couldn't be helpful

Thank you for your feedback

Let us how can we improve this article!

Select atleast one of the reasons

Feedback sent

We apprciate your effort and will try to fix the article