How to fix incompatible issue on M2.3.6?

Created by Rosa Truong, Modified on Fri, 09 Apr 2021 at 10:06 AM by Rosa Truong

Issue:

 

I have an issue after Magento setup upgrade - 
 "Warning: Declaration of Bss\MultiStoreViewPricingPriceIndexer\Model\Indexer\Product\Price\TableMaintainer::getMainTable(array $dimensions): string should be compatible with Magento\Framework\Model\Re  
  sourceModel\Db\AbstractDb::getMainTable() in /app/code/Bss/MultiStoreViewPricingPriceIndexer/Model/Indexer/Product/Price/TableMaintainer.php on line 138
Could you please help with update for Magento 2.3.6?


Solution: 


Our module is not compatible with Magento 2.3.6 at this time, so it causes the issue.

To solve this issue, we would like to give you the guide as below:

Step 1: Change the file app/code/Bss/MultiStoreViewPricingPriceIndexer/Model/Indexer/Product/Price/TableMaintainer.php

Step 2: Replace the fixed file on the site

Step 3: Clear the cache

Please check and follow our guide.


If you need any further support, please feel free to contact us.

We'd like to help.


Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry! We couldn't be helpful

Thank you for your feedback

Let us how can we improve this article!

Select atleast one of the reasons

Feedback sent

We apprciate your effort and will try to fix the article