How to fix the incompatible issue on M2.3.1?

Created by Rosa Truong, Modified on Mon, 14 Dec 2020 at 03:35 PM by Rosa Truong

Issue

We have installed Fast Order v1.3.3 for Magento at the clean installation at M2.3.1 version and the extension has errors.



Solution:

The issue is caused due to the fact that the current version is not compatible with M2.3.1 at this time.

The class jquery-ui-modules/widget is only on M2.3.5 and higher versions.

We would like to give the hot-fix solution to solve this issue.

Step 1: Edit these files:

app/code/Bss/FastOrder/view/frontend/web/js/configurable.js

app/code/Bss/FastOrder/view/frontend/web/js/custom/downloadable.js

app/code/Bss/FastOrder/view/frontend/web/js/custom/grouped.js

app/code/Bss/FastOrder/view/frontend/web/js/custom/price/option.js

app/code/Bss/FastOrder/view/frontend/web/js/downloadable.js

app/code/Bss/FastOrder/view/frontend/web/js/fastorder-swatch.js

app/code/Bss/FastOrder/view/frontend/web/js/fastorder.js

app/code/Bss/FastOrder/view/frontend/web/js/grouped.js

app/code/Bss/FastOrder/view/frontend/web/js/integrate/configurable-grid-view.js

app/code/Bss/FastOrder/view/frontend/web/js/integrate/request-for-quote.js

app/code/Bss/FastOrder/view/frontend/web/js/price-options.js

app/code/Bss/FastOrder/view/frontend/web/js/product/view/option.js

app/code/Bss/FastOrder/view/frontend/web/js/select-option.js

Step 2: Apply the files and the site and flush the cache.


Please check and follow our guide.


If you need any further support, please feel free to contact us.

We're always willing to support you.


Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry! We couldn't be helpful

Thank you for your feedback

Let us how can we improve this article!

Select atleast one of the reasons

Feedback sent

We apprciate your effort and will try to fix the article