QUESTION:


In the configurable grid view extension, I am testing it with 2.4.4 because I need to upgrade to the latest version.



It's not showing the elements, if I disable the extension, then it shows the dropdown box as per the standard behaviour... but if I enable the extension I don't see the fields, all I see is an empty grid with Add to Cart button.


I'm using PHP8.1 and Magento 2.4.4CE on the local machine.


Can you let me know how to resolve this issue, please?


ANSWER:


To fix the incompatible error between our module with M2.4.4 (php8.1), please edit the file app/code/Bss/ConfiguableGridView/Helper/Data.php as below:



Or upload the attached file below to override the current file on your site.


If there are any questions or concerns, please feel free to contact us.