Require PHP version

Created by Nicole Le, Modified on Thu, 15 Aug 2019 at 09:10 AM by Nicole Le


I got many issues like Package bsscommerce/configurable-product-matrix-view at version  has a PHP requirement incompatible with your PHP version (7.2.14).


Using --ignore-platform-reqs, I could install it but after that it started to show error on Magento cloud while pushing code.


    W:     - bsscommerce/configurable-product-matrix-view 1.0.1 requires php ~5.5.0|~5.6.0|7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.2.11) does not satisfy that requirement.


This error was due to the require PHP version in file composer.json

You only need delete this require element on file:

Afterward, install extension normally or via composer with the new composer.json file.

Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry! We couldn't be helpful

Thank you for your feedback

Let us know how can we improve this article!

Select atleast one of the reasons

Feedback sent

We appreciate your effort and will try to fix the article